您的位置:首页 > 其它

hdoj 2680 Choose the best route

2015-06-04 16:10 239 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8927 Accepted Submission(s):
2900


[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As
she is liable to carsickness , she wants to arrive at her friend’s home as soon
as possible . Now give you a map of the city’s traffic route, and the stations
which are near Kiki’s home so that she can take. You may suppose Kiki can change
the bus at any station. Please find out the least time Kiki needs to spend. To
make it easy, if the city have n bus stations ,the stations will been expressed
as an integer 1,2,3…n.

[align=left]Input[/align]
There are several test cases.
Each case begins with
three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the
number of bus stations in this city and m stands for the number of directed ways
between bus stations .(Maybe there are several ways between two bus stations .)
s stands for the bus station that near Kiki’s friend’s home.
Then follow m
lines ,each line contains three integers p , q , t (0<t<=1000). means from
station p to station q there is a way and it will costs t minutes .
Then a
line with an integer w(0<w<n), means the number of stations Kiki can take
at the beginning. Then follows w integers stands for these stations.

[align=left]Output[/align]
The output contains one line for each data set : the
least time Kiki needs to spend ,if it’s impossible to find such a route ,just
output “-1”.

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2

2 3

4 3 4
1 2 3
1 3 4
2 3 2
1
1

[align=left]Sample Output[/align]

1
-1

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 1100
#define INF 0x3f3f3f
using namespace std;
int visit[MAX],map[MAX][MAX],low[MAX],time[MAX];
int sta;
int tou;
bool cmp(int a,int b)
{
return a<b;
}
void dijkstra(int tou)
{
int j,i,min,next;
memset(visit,0,sizeof(visit));
for(i=1;i<=sta;i++)
low[i]=map[tou][i];
visit[tou]=1;
for(i=1;i<sta;i++)
{
min=INF;
for(j=1;j<=sta;j++)
{
if(!visit[j]&&min>low[j])
{
min=low[j];
next=j;
}
}
visit[next]=1;
for(j=1;j<=sta;j++)
{
if(!visit[j]&&low[j]>low[next]+map[next][j])
low[j]=low[next]+map[next][j];
}
}
}
int main()
{
int i,j,m,p,q,t,w,sum,k;
while(scanf("%d%d%d",&sta,&m,&tou)!=EOF)
{
memset(time,0,sizeof(time));
for(i=1;i<=sta;i++)
{
for(j=1;j<=sta;j++)
{
if(i==j)
map[i][j]=0;
else
map[i][j]=INF;
}
}
while(m--)
{
scanf("%d%d%d",&p,&q,&t);
if(map[q][p]>t)
map[q][p]=t;    //注意此处,因为此题计算时是将终点作为起点计算的
}                    //所以此处给map数组赋值时要注意
dijkstra(tou);
scanf("%d",&w);
for(i=0;i<w;i++)
{
scanf("%d",&k);
time[i]=low[k];
}
sort(time,time+w,cmp);
if(time[0]==INF)
printf("-1\n");
else
printf("%d\n",time[0]);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: