您的位置:首页 > 其它

poj1195 Mobile phones

2015-06-03 18:03 302 查看
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table.



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output
3
4
这题可以用二维树状数组做,感觉二维数组就是一维数组的平方形式,加一个维数,然后循环变为两个,理解了的话并不难。这里要注意,矩形的坐标都要加1(即所有坐标都向右上移动一位),这么做事为了使后面算矩形面积用到getsum(f,g)+getsum(d-1,e-1)-getsum(f,e-1)-getsum(d-1,g)这个公式的时候避免出现d-1=0或者e-1=0,因为lowbit(0)=0,这样会陷入无限循环,还有就是maxn的大小不能开成2^k,如2048,因为这样做当i达到2048的时候,数组a[2048][2048]会越界,当然也可以处理一下把数组开到略大于maxn。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 2000
int b[maxn][maxn];
int lowbit(int x){
	return x&(-x);
}

void update(int x,int y,int num)
{
	int i,j;
	for(i=x;i<=maxn;i+=lowbit(i)){
		for(j=y;j<=maxn;j+=lowbit(j)){
			b[i][j]+=num;
		}
	}
}

int getsum(int x,int y)
{
	int num=0,i,j;
	for(i=x;i>0;i-=lowbit(i)){
		for(j=y;j>0;j-=lowbit(j)){
			num+=b[i][j];
		}
	}
	return num;
}

int main()
{
	int n,m,i,j,c,d,f,g,e;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		memset(b,0,sizeof(b));
		while(1)
		{
			scanf("%d",&c);
			if(c==3)break;
			if(c==1){
			   scanf("%d%d%d",&d,&e,&f);
			   d++;e++;//f++;
			   update(d,e,f);
		    }
		    else if(c==2){
			   scanf("%d%d%d%d",&d,&e,&f,&g);
			   d++;e++;f++;g++;
			   printf("%d\n",getsum(f,g)+getsum(d-1,e-1)-getsum(f,e-1)-getsum(d-1,g));
		    }
		}
		
	}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: