您的位置:首页 > 其它

[POJ 1328] Radar Installation

2015-06-02 23:45 309 查看
Radar Installation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 59563Accepted: 13430
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


区间选点问题

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;
#define N 1010

struct P
{
double x1,x2;
bool operator < (const P &t)const
{
if(x2!=t.x2) return x2<t.x2;
return x1>t.x1;
}
}p
;

int main()
{
int n,r;
int iCase=1;
int end_flag;
while(scanf("%d%d",&n,&r),n||r)
{
end_flag=0;
for(int i=1;i<=n;i++)
{
double x,y;
scanf("%lf%lf",&x,&y);
if(y>r) end_flag=1;
p[i].x1=x-sqrt(r*r-y*y);
p[i].x2=x+sqrt(r*r-y*y);
}
printf("Case %d: ",iCase++);
if(end_flag)
{
printf("-1\n");
continue;
}
sort(p+1,p+n+1);
int cnt=1;
double tmp=p[1].x2;
for(int i=2;i<=n;i++)
{
if(p[i].x1>tmp)
{
cnt++;
tmp=p[i].x2;
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: