您的位置:首页 > 其它

POJ2406 Power Strings(KMP next数组的运用)

2015-06-02 11:38 435 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 36160Accepted: 14929
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3


Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:

给定一个串,求能分成几个相等的子串。

解题思路:

利用求KMP next数组的方法,next表示模式串如果第i位(设p[0]为第0位)与文本串第j位不匹配则要回到第next[i]位继续与文本串第j位匹配。则模式串第1位到next
与模式串第n-next
位到n位是匹配的。

AC代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;

const int maxn = 1000001;
int next[maxn];

int Compute_next(string p)
{
int len = p.length();
memset(next,0,sizeof(next));
next[0] = -1; //没有公共前后缀
int i = 0,j = -1; //i为母串当前匹配的位置,j为子串当前匹配位置
while(i <= len)
{
if(j == -1 || p[i] == p[j])
{
i++; //匹配两个指针都往后移
j++;
next[i] = j; //记录next数组,表示p[1...j]与p[i-j+1..i]是完全相等的
}
else
{
j = next[j]; //如果不匹配,就回退到j位置
}
}
int x = len - next[len]; //已匹配的串位置
if(len % x == 0 && x != 0)
{
return x;
}
else
{
return len;
}
}

int main()
{
string a;
while(cin>>a)
{
int len = a.length();
if(a[0] == '.')
{
break;
}
else
{
int res = Compute_next(a);
cout<<len / res <<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: