您的位置:首页 > 其它

字符串水题(hdoj1049)

2015-06-01 23:46 351 查看
[align=left]Problem Description[/align]
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in
the quality control department, and it's your job to test the generator and make
sure that the passwords are acceptable. To be acceptable, a password must
satisfy these three rules:

It must contain at least one vowel.

It
cannot contain three consecutive vowels or three consecutive
consonants.

It cannot contain two consecutive occurrences of the same
letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the
vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note
that these rules are not perfect; there are many common/pronounceable words that
are not acceptable.

[align=left]Input[/align]
The input consists of one or more potential passwords,
one per line, followed by a line containing only the word 'end' that signals the
end of the file. Each password is at least one and at most twenty letters long
and consists only of lowercase letters.

[align=left]Output[/align]
For each password, output whether or not it is
acceptable, using the precise format shown in the example.

[align=left]Sample Input[/align]

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

[align=left]Sample Output[/align]

<a> is acceptable.

<tv> is not acceptable.
<ptoui> is not acceptable.

<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.

<eep> is acceptable.
<houctuh> is acceptable.

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char b[5]={'a','e','i','o','u'},c[21]={'b','c','d','f','g','h','j','k','l','m','n','p','q','r','s','t','v','w','x','y','z'};
char d[]={'a','i','u','b','c','d','f','g','h','j','k','l','m','n','p','q','r','s','t','v','w','x','y','z'};
char a[21];
int len;
int vowels()
{
int i,k,j;
int flag;
for(i=0;i<len-2;i++)
{
flag=0;
for(j=0;j<3;j++)
{
for(k=0;k<5;k++)
{
if(a[i+j]==b[k])
{
flag++;
break;
}
}
}
if(flag==3)
return 0;
}
return 1;
}
int consonants()
{
int i,k,j;
int flag;
for(i=0;i<len-2;i++)
{
flag=0;
for(j=0;j<3;j++)
{
for(k=0;k<21;k++)
{
if(a[i+j]==c[k])
{
flag++;
break;
}
}
}
if(flag==3)
return 0;
}
return 1;
}
int consecutive_occurrences()
{
int i,j,k;
bool flag;
for(i=0;i<len-1;i++)
{
flag=0;
if(a[i]==a[i+1])
{
for(j=0;j<24;j++)
if(a[i]==d[j])
{
flag=1;
break;
}
}
if(flag)
return 0;
}
return 1;
}
int main()
{
char b[4]="end";
while(cin>>a)
{
getchar();
if(strcmp(a,b)==0)
break;
len=strlen(a);
int k=0;
if((strchr(a,'a')!=NULL)||(strchr(a,'e')!=NULL)||(strchr(a,'i')!=NULL)||(strchr(a,'o')!=NULL)||(strchr(a,'u')!=NULL))
k++;
if(vowels()&&consonants())
k++;
if(consecutive_occurrences ())
k++;
if(k==3)
cout<<'<'<<a<<'>'<<" is acceptable."<<endl;
else
cout<<'<'<<a<<'>'<<" is not acceptable."<<endl;
memset(a,0,sizeof(a));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: