您的位置:首页 > 其它

hdu 1170 Balloon Comes

2015-06-01 22:29 323 查看

Balloon Comes!

气球来了!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22727 Accepted Submission(s): 8577



Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU,
现在比赛开始!气球升起激动的时刻来了。你作为HDU优秀的编程员之一。
can get a very beautiful balloon if only you have solved the very very very... easy problem.
如果能解决这个非常非常非常难的问题,那么你就可以得到一个美丽的气球。

Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively)
你(respectively分别)能用,(addition加),(subtraction减),(multiplication乘),(division除),(denoting 指示)
and two positive integers, your task is to output the result.
两个整正数,你的任务是输出他们的结果。

Is it very easy?
很简单吧?

Come on, guy! PLMM will send you a beautiful Balloon right now!
小子,来吧!漂亮美眉会立刻给你一个么美丽的气球!

Good Luck!

祝你好运!

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases.
输入包含多个测试用例。输入的第一行是T,T指的是有多少个测试用例。
T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).
然后T行。每一行包含一个字符和两个数字,字符为( + - * / ),A , B(0<A,B<10000)。
Of course, we all know that A and B are operands and C is an operator.

当然,A C B = D,也就是C是运算符,D是A与B运算的答案。

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

对于每一个测试用例,输出结果。(小数***)结果应四舍五入小数点后2位(当且仅当它不是一个整数------注意:如果结果不是小数就不要精确)。

Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2




Sample Output
3
-1
2
0.50


这题没压力啊!!

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int t = sc.nextInt();
		while (t-- > 0) {
			String str = sc.next();
			int a = sc.nextInt();
			int b = sc.nextInt();
			switch (str.charAt(0)) {
			case '+':
				str = "" + (a + b);
				break;
			case '-':
				str = "" + (a - b);
				break;
			case '*':
				str = "" + (a * b);
				break;
			case '/':
				if (a / b * b == a) {
					str = "" + (a / b);
				} else {
					str = String.format("%.2f", 1.0 * a / b);
				}
				break;
			default:
				break;
			}
			System.out.println(str);
		}
	}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: