您的位置:首页 > 其它

杭电acm 1019 Least Common Multiple

2015-05-30 17:57 393 查看
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.



Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.



Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.



Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1




Sample Output
105
10296




//一道简单题错了这么多次,就是因为__int64最后数据太大的问题

#include<cstdio>

int fun(int max,int min)
{
	int c,t;
	if(max<min)
	{
		t=min;
		min=max;
		max=t;
	}
	int a=max,b=min;	
	while(min!=0)
	{
		c=max%min;
		max=min;
		min=c;				
	}	
	return max;	
}
int main()
{
	int t,n,i,a;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		__int64 res=1;
		for(i=1;i<=n;++i)
		{
			scanf("%d",&a);
			res=res*a/fun(res,a);
		}	
						
		printf("%I64d\n",res);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: