您的位置:首页 > 其它

poj 2240 Arbitrage 【最短路】 【更新:用STL map处理字符串】

2015-05-28 22:20 435 查看
Arbitrage
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17170Accepted: 7248
Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

floyd:暴力每次遍历所有字符串,后面有更新的

#include <cstdio>
#include <cstring>
#define MAX 40
using namespace std;
double map[MAX][MAX];
char str[MAX][MAX];
char a[MAX], b[MAX];
int n, m;
int p = 1;
void getmap()
{
    int i, j;
    int x, y;
    double rate;
    memset(map, 0, sizeof(map));
    for(i = 0; i < n; i++)
    {
        scanf("%s", str[i]);
        for(j = 0; j < n; j++)
        {
            map[i][j] = 1;
        }
    }
    scanf("%d", &m);
    for(i = 0;i < m; i++)
    {
        scanf("%s%lf%s", a, &rate, b);
        x = y = -1;
        for(j = 0;j < n; j++)
        {
            if(strcmp(a, str[j]) == 0)
            x = j;
            if(strcmp(b, str[j]) == 0)
            y = j;
            if(x != -1 && y != -1)
            break;
        }
        map[x][y] = rate;
    }
}
void floyd()
{
    int k, i, j;
    for(k = 0; k < n ;k++)
    {
        for(i = 0; i < n; i++)
        {
            for(j = 0; j < n; j++)
            {
                if(map[i][j] < map[i][k] * map[k][j])
                map[i][j] = map[i][k] * map[k][j];
            }
        }
    }
}
void slove()
{
    int i;
    int exist = 0;
    printf("Case %d: ", p++);
    for(i = 0; i < n; i++)
    {
        if(map[i][i] > 1)
        {
            exist = 1;
            break;
        }
    }
    if(exist)
    printf("Yes\n");
    else
    printf("No\n");
}
int main()
{
    while(scanf("%d", &n), n)
    {
        getmap();
        floyd();
        slove();
    }
    return 0;
}

每次都遍历很多字符串,这样很麻烦,我们可以建立map<string, int>cur的一个映射,来记录字符串的出现顺序。

更新时间:2015.6.23

#include <cstdio>
#include <cstring>
#include <map>
#include <string>
#define MAX 40
using namespace std;
double Map[MAX][MAX];
char str[MAX];
char a[MAX], b[MAX];
int n, m;
int p = 1;
map<string, int> cur;
void getMap()
{
    int i, j;
    double rate;
    for(i = 1; i <= n; i++)
    {
        scanf("%s", str);
        for(j = 1; j <= n; j++)
        {
            Map[i][j] = 1;
        }
    }
    scanf("%d", &m);
    int num = 1;
    cur.clear();
    while(m--)
    {
        scanf("%s%lf%s", a, &rate, b);
        if(!cur[a]) cur[a] = num++;
        if(!cur[b]) cur[b] = num++;
        Map[cur[a]][cur[b]] = rate;
    }
}
void floyd()
{
    int k, i, j;
    for(k = 1; k <= n ;k++)
    {
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                if(Map[i][j] < Map[i][k] * Map[k][j])
                Map[i][j] = Map[i][k] * Map[k][j];
            }
        }
    }
}
void slove()
{
    int i;
    int exist = 0;
    printf("Case %d: ", p++);
    for(i = 1; i <= n; i++)
    {
        if(Map[i][i] > 1)
        {
            exist = 1;
            break;
        }
    }
    if(exist)
    printf("Yes\n");
    else
    printf("No\n");
}
int main()
{
    while(scanf("%d", &n), n)
    {
        getMap();
        floyd();
        slove();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: