您的位置:首页 > 编程语言 > C语言/C++

HDOJ 1001 Sum Problem 累加求和的高效率版的C语言实现

2015-05-27 21:02 585 查看

Sum Problem

[b]Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 336059 Accepted Submission(s): 84538[/b]

[align=left][/align]
Problem Description
Hey, welcometo HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The inputwill consist of a series of integers n, one integer per line.

Output
For eachcase, output SUM(n) in one line, followed by a blank line. You may assume theresult will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050
#include <stdio.h>

int main()
{
int sum,n;
while(scanf("%d",&n)!=EOF){
sum=(1+n)*(n>>1); //和为n/2倍的首尾整数相加的和
if(n%2==1){ //如果n为奇数,和就再加上中间(第n/2+1个)那个数
sum+=(n>>1)+1;
}
printf("%d\n\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: