您的位置:首页 > 其它

UVA1368 - DNA Consensus String

2015-05-25 13:41 405 查看
DNA Consensus String


Time
limit: 3.000 seconds



DNA (Deoxyribonucleic Acid) is the molecule
which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence
of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:

"Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"

Then we can represent the above DNA strand with the
string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal
were very alike. See Figure 2.

DNA sequence of gene X

Cat:GCATATGGCTGTGCA

Dog:GCAAATGGCTGTGCA

Horse:GCTAATGGGTGTCCA

Cow:GCAAATGGCTGTGCA

Monkey:GCAAATCGGTGAGCA

Figure 2. DNA sequences of gene X in five animals.

Prof. Ahn thought that humans might also have the
gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming
distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings "AGCAT" and "GGAAT." The Hamming distance of these
two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,..., sm of length n , the
consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and each si in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of
S . For example, given the three strings "AGCAT" "AGACT" and "GGAAT" the consensus string of the given strings is "AGAAT" because the sum of the Hamming distances between "AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string
is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is "GCAAATGGCTGTGCA" and the consensus error is 7.

Input

Your program is to read from standard input. The
input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers m and n which are separated by a single space. The integer m (4$ \le$m$ \le$50) represents the number
of DNA sequences and n (4$ \le$n$ \le$1000) represents the length of the DNA sequences, respectively. In each of the next m lines, each DNA sequence is given.

Output

Your program is to write to standard
output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input
and output for three test cases.

Sample Input

3

5 8

TATGATAC

TAAGCTAC

AAAGATCC

TGAGATAC

TAAGATGT

4 10

ACGTACGTAC

CCGTACGTAG

GCGTACGTAT

TCGTACGTAA

6 10

ATGTTACCAT

AAGTTACGAT

AACAAAGCAA

AAGTTACCTT

AAGTTACCAA

TACTTACCAA

Sample Output

TAAGATAC

7

ACGTACGTAA

6

AAGTTACCAA

12

本题题意是输入
m 个长度为 n 的DNA序列,求一个DNA序列,使得序列到所有所给序列的总Hamming距离尽量最小。Hamming距离是两个等长字符串的字符不同的位置个数。例如,ACGT 和 GCGA的Hamming距离为2(左数第1,4个字符不同)。因为每个字符串的字符是相互独立的,因此只要找出字符串每一位出现最多的字符则是所求DNA序列,当出现次数相同时,则取字典序较小的一个。

<span style="color:#330033;">#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=10e4+10;
char dna[60][maxn];

int main()
{
int z;
scanf("%d",&z);
while(z--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i = 0; i < n; i++)
scanf("%s",dna[i]);
char str[maxn];
int sum = 0;
for(int i = 0; i < m; i++)
{
int marka = 0, markc = 0, markg = 0, markt = 0;///分别标记AGTC出现次数
for(int j=0;j<n;j++)
{
switch(dna[j][i])
{
case 'A': marka++;break;
case 'C': markc++;break;
case 'G': markg++;break;
case 'T': markt++;break;
}
}
///比较找出出现次数最多的字母,并用str数组记录,以及计算Hamming距离
if(marka >= markc && marka >= markg && marka >= markt)
{
str[i] = 'A';
sum += n - marka;
}
else if(markc >= marka && markc >= markg && markc >= markt)
{
str[i] = 'C';
sum += n - markc;
}
else if(markg >= marka && markg >= markc && markg >= markt)
{
str[i] = 'G';
sum += n - markg;
}
else
{
str[i] = 'T';
sum += n - markt;
}
}
str[m] = '\0';
printf("%s\n%d\n",str,sum);
}
return 0;
}</span>


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: