您的位置:首页 > 其它

poj1328 Radar Installation

2015-05-25 02:02 337 查看
Radar Installation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 59264Accepted: 13349
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

Source

Beijing 2002

题意大概就是,给出几个坐标,问最少的圆能覆盖所有点的数目。还有非法的可能。

贪心吧

#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
int n,d;
struct point
{
int x,y;
double xx;
}p[1010];
int flag;
bool compare(point a,point b)
{
return a.xx<b.xx;
}
int vis[1010];
int main()
{
int _case=0;
while(cin>>n>>d)
{
flag=0;
if(n==0&&d==0) break;

for(int i=1;i<=n;i++)
{
cin>>p[i].x>>p[i].y;
if(p[i].y>d) flag=1;
else
{
p[i].xx=p[i].x+sqrt(d*d-p[i].y*p[i].y);
}
}
if(flag==1)
{
cout<<"Case "<<++_case<<": ";
cout<<"-1"<<endl;
continue;
}
sort(p+1,p+n+1,compare);
int cnt=0;
memset(vis,0,sizeof(vis));
//cout<<"asdf";
for(int i=1;i<=n;i++)
{
if(!vis[i])
{
cnt++;
for(int j=1;i+j<=n;j++)
{
if(((p[i].xx-p[i+j].x)*(p[i].xx-p[i+j].x)+p[i+j].y*p[i+j].y)<=d*d)
{
vis[i+j]=1;
}
else break;
}
}
}
cout<<"Case "<<++_case<<": ";
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: