您的位置:首页 > 编程语言 > C语言/C++

HDU-1031- Design T-Shirt(c++ && 简单模拟)

2015-05-24 20:12 381 查看


Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6657 Accepted Submission(s): 3125



Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll
to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only
put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines
follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The
indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2


Sample Output

6 5 3 1
2 1


Author

CHEN, Yue

Source

CYJJ's Funny Contest #1, Killing in Seconds

Recommend

Ignatius.L | We have carefully selected several similar problems for you: 1036 1032 1033 1037 1039

多谢傅联洲同学分享的思路,你的算法实在是精妙无比......

好了说一下题目的大意!(分数不一定是整型)

大概意思就是XKA打算设计一个T-Shirt,征集大众对这个T-Shirt的满意度!

首先输入三个数:N,M,K(N表示打分的人数,M表示分数的总数量,K表示XKA所要选用的)

XKA将会选用分值最高的前K个元素,如果分值相同则选择靠前的元素!

另外要注意的输出格式,不能有多余的空格。

思路:1.比较每一列的和的大小。

2.记录每次比较后和最大的列数。

3.安大小输出列数,若列数相同,输出靠前的。

4.格式。

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAX 1000
double a[300][300],b[300];
using namespace std;
int main()
{
int m,n,k,i,j;
while(scanf("%d%d%d",&n,&m,&k)!=EOF)
{
for(i=0;i<n;i++)
for(j=0;j<m;j++)
scanf("%lf",&a[i][j]);           //输入每个人打的分数
for(j=0;j<m;j++)
{
double sum=0;
for(i=0;i<n;i++)
{
sum+=a[i][j];                    //求出每列的分数和,每列对应一个题目
}
b[j]=sum;
}
int f[MAX];
memset(f,0,sizeof(f));
for(i=0;i<k;i++)
{
double max=b[0];
int flag = i;                        //记录最大分数和的下标
for(j=m-1;j>=0;j--)
{
if(max-b[j]<10e-6)               //比较求出最大分数和的值,标记下来
{
max=b[j];
flag=j;
}
}
f[flag+1]=1;
b[flag]=0;                           //将最大的数去除
}
int p=1;
for(i=MAX-1;i>=0;i--)
{
if(f[i])
{
if(p)p=0;
else
printf(" ");                 //格式化输出
printf("%d",i);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: