您的位置:首页 > 其它

HDU 1213 How Many Tables (并查集)

2015-05-24 11:49 197 查看
#include <stdio.h>
#include <iostream>
using namespace std;

int ff[100005];//ff[x]表示x的父节点
int ss[100005];//

void ii(int n)    //初始化
{
for(int i=1;i<=n;i++)
{
ff[i]=i;
}
}

int dd(int x)    //带路径压缩的查找
{
if(x!=ff[x])
ff[x] = dd(ff[x]);
return ff[x];
}

int main()
{
int i,t,k,j,N,m,n,a,b,A,B;
int count,max=0,ans;
scanf("%d",&N);
while(N--)
{
ii(100005);
t=0;
scanf("%d%d",&m,&n);
while(n--)
{
scanf("%d%d",&a,&b);
int x=dd(a);
int y=dd(b);
ff[x] = y;
}
for(i=1;i<=m;i++)
{
if (ff[i] == i)
{
t++;
}
}
printf("%d\n",t);
}
return 0;
}


分析:一开始并没有用查找的函数,个人认为直接ff[a] = b ;就可以了,后来考虑到下面这种情况: 1 2 1 3 如果是不用查找的话,输出结果为2 但实际上只有1

所以 还是得用路径压缩的查找函数,最后再判断 ff[i] == i 来判断是否需要增加桌子


How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17126 Accepted Submission(s): 8385



Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


Author

Ignatius.L

Source

杭电ACM省赛集训队选拔赛之热身赛

#include <iostream>
using namespace std;

int ff[1001];

void ii(int x)
{
for(int i = 1;i <= x;i++)
{
ff[i] = i;
}
}

int dd(int x)
{
while(x != ff[x])
{
x = ff[x];
}
return x;
}

void cc(int a,int b )
{
int ta = dd(a);
int tb = dd(b);
if(ta != tb)
{
ff[ta] = tb;
}
}

int main()
{
int t,m,n;
int i,j,k;
int cnt;

cin>>t;
while(t--)
{
cin>>n>>m;
ii(n);
cnt = 0;
for(i =1;i<=m;i++)
{
cin>>j>>k;
cc(j,k);
}
for(i = 1;i<=n;i++)
{
if(dd(i) == i)
{
cnt++;
}
}
cout<<cnt<<endl;
}
return 0;
}


2015-10-26
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: