您的位置:首页 > 其它

Candy Sharing Game(hdoj1034)

2015-05-21 23:42 253 查看
[align=left]Problem Description[/align]
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a
program which determines the number of times the teacher blows the whistle and
the final number of pieces of candy for each student from the amount of candy
each child starts with.

[align=left]Input[/align]
The input may describe more than one game. For each
game, the input begins with the number N of students, followed by N (even) candy
counts for the children counter-clockwise around the circle. The input ends with
a student count of 0. Each input number is on a line by itself.

[align=left]Output[/align]
For each game, output the number of rounds of the game
followed by the amount of candy each child ends up with, both on one
line.

[align=left]Sample Input[/align]

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2

4
6
8
0

[align=left]Sample Output[/align]

15
14

17
22
4
8

目说的是一个分糖果的游戏,n个学生围成一圈,每个人手上有a[i]个糖果,每一轮游戏开始时,学生手中的糖果都是偶数,他们都把自己手中一半的糖果分给他右边的同学。分完后手中糖果数是奇数的,老师会给他一颗糖果。如果所有人手中的糖果数都一样 游戏结束。

输出总共进行了多少轮游戏 还有最后学生手中的糖果数。

#include <iostream>
using namespace std;
int f(int a[],int n)     //判断是否分配结束
{
int i;
for(i=0;i<n-1;i++)
if(a[i]!=a[i+1])
return 1;
return 0;
}
int main()
{
int n;

while(cin>>n&&n)
{
int a[500],i,x=0,y;
for(i=0;i<n;i++)
cin>>a[i];
while(f(a,n))
{
x++;
y=a[n-1]/2;
for(i=n-1;i>0;i--)
{
a[i]=a[i]/2+a[i-1]/2;
if(a[i]%2)
a[i]++;
}
a[0]=a[0]/2+y;
if(a[0]%2)
a[0]++;
}
cout<<x<<" "<<a[0]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: