您的位置:首页 > 其它

How Many Equations Can You Find

2015-05-19 16:49 423 查看

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 604 Accepted Submission(s): 395

Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer
N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.


Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.


Output
The output contains one line for each data set : the number of ways you can find to make the equation.


Sample Input
123456789 3
21 1




Sample Output
18
1


分析,强大的dfs,来自于 学姐 的博客。

code:

<pre name="code" class="cpp">#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
__int64 num,n,len;
char str[15];
void DFS(__int64 x,__int64 sum)
{
    if(x==len)
    {
        if(sum==n)
            num++;
        return ;
    }
    __int64 k=0;//orz,跪了。
    for(int i=x;i<len;i++)
    {
        k=k*10+str[i]-'0';
        DFS(i+1,sum+k);
        if(x!=0)//第一个数字前不能加“-”号
            DFS(i+1,sum-k);
    }
}
int main()
{
    while(scanf("%s %I64d",str,&n)!=EOF)
    {
        len=strlen(str);
        num=0;
        DFS(0,0);
        printf("%I64d\n",num);
    }
    return 0;
}



<span style="font-size:18px;">
</span>
<span style="font-size:18px;">一入搜索深似海,从此AC是路人!!!<img alt="抓狂" src="http://static.blog.csdn.net/xheditor/xheditor_emot/default/crazy.gif" /><img alt="抓狂" src="http://static.blog.csdn.net/xheditor/xheditor_emot/default/crazy.gif" /><img alt="抓狂" src="http://static.blog.csdn.net/xheditor/xheditor_emot/default/crazy.gif" /></span><span style="font-size:18px;"></span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: