您的位置:首页 > 编程语言 > C语言/C++

HDU-1022-Train Problem I(C++ && 简单堆栈)

2015-05-18 11:37 363 查看


Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24737 Accepted Submission(s): 9316



Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312


Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you: 1026 1023 1032 1010 1003

题目说了这么多,其实就是一个简单的堆栈问题,读入数字n,读取两个字符串,字符串1是入栈的顺序,字符串2要求是出栈的顺序!

入栈的顺序不变,但是中途入栈的元素可以出栈,看是否能够满足字符串2的出栈顺序,如果可以输出Yes.然后把里面的入栈出栈的顺序

全部写出来,我这里是看了网友的写法,觉得实在是很好,用了C++STL库里面的stack,Java没有类似这样的stack的类库......如果用Java

写的话还得重新写push,pop,top,empty方法,果断c++走起!

#include<cstdio>
#include<cstring>
#include<stack>
#include<iostream>
using namespace std;
int main()
{
int n,j, k, flag[50];                         //flag数组记录入栈出栈顺序
char s1[15], s2[15];
stack <char> s;
while(~scanf("%d %s%s",&n,s1,s2))
{
while(!s.empty()) s.pop();
memset(flag,-1,sizeof(flag));
j = k = 0;
for(int i=0;i<n;i++)
{
s.push(s1[i]);
flag[k++]=1;
while(!s.empty()&&s.top()==s2[j])      //如果栈不为空并且栈顶元素等于当前出栈的元素!
{
s.pop();                           //出栈
flag[k++]=0;                       //标记出栈
j++;                               //记录出栈次数
}
}
if(j==n)
{
printf("Yes.\n");
for(int i=0;i<k;i++)
{
if(flag[i])
{
printf("in\n");
}
else
{
printf("out\n");
}
}
}
else
{
printf("No.\n");
}
printf("FINISH\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: