您的位置:首页 > 其它

POJ 3624 Charm Bracelet (01背包)

2015-05-16 23:00 288 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 26078Accepted: 11726
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

解题思路:

  又是一道01背包的模板题,其实只要把握清楚思想就好了,用一维来搞,用二维会爆掉。。。

代码:

# include<cstdio>
# include<iostream>
# include<cstring>

using namespace std;

# define MAX 3555

int a[MAX],b[MAX];
int dp[MAX*MAX];

int main(void)
{
int n,m;
while ( scanf("%d%d",&n,&m)!=EOF )
{
memset(dp,0,sizeof(dp));
for ( int i = 0;i < n;i++ )
{
scanf("%d%d",&a[i],&b[i]);
}
for ( int i = 0;i < n;i++ )
{
for ( int j = m;j >= a[i];j-- )
{
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
}
printf("%d\n",dp[m]);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: