您的位置:首页 > 其它

POJ 1426 Find The Multiple

2015-05-16 22:40 323 查看
Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 20297Accepted: 8236Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define N 1000009
#define ll __int64
using namespace std;

int n;
int flag;

void dfs(unsigned ll x,int k)//注意使用无符号64位整数
{
    if(flag) return;

    if(x%n==0)
    {
       printf("%I64u\n",x);
        flag=1;
        return;
    }

    if(k==19) return;//最大19位

    dfs(x*10,k+1);
    dfs(x*10+1,k+1);
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;

        flag=0;

        dfs(1,0);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: