您的位置:首页 > 其它

UVa 455 - Periodic Strings

2015-05-15 22:56 260 查看
Periodic Strings

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1 HoHoHo

Sample Output

2

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
char s[100];
scanf("%s",s);
int len=strlen(s);
for(int j=1;;j++)
{
if(len%j==0)
{
bool key=true;
for(int k=0;k<len;k++)
{
if(s[k]!=s[k%j])
{
key=false;
break;
}
}
if(key)
{
printf("%d\n",j);
break;
}
}
}
if(i!=n-1)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: