您的位置:首页 > 其它

POJ 3278 catch that cow

2015-05-15 20:07 288 查看
Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 54696Accepted: 17101
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#define N 100009
using namespace std;

int n,k;
int vis
;
int a
;
int t;

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        if(n==k)
        {
            cout<<0<<endl;
            continue;
        }

        memset(a,0,sizeof a);
        memset(vis,0,sizeof vis);

         queue<int>q;
        q.push(n);

        while(!q.empty())
        {
            t=q.front();
            q.pop();

            if(t+1<N && vis[t+1]==0)
            {
                vis[t+1]=1;
                q.push(t+1);
                a[t+1]=a[t]+1;
            }
            if(t+1==k) {break;}

            if(t-1>=0 && vis[t-1]==0)
            {
                vis[t-1]=1;
                q.push(t-1);
                a[t-1]=a[t]+1;
            }
            if(t-1==k) {break;}

            if(t*2<N && vis[t*2]==0)
            {
                vis[t*2]=1;
                q.push(t*2);
                a[t*2]=a[t]+1;
            }
            if(t*2==k) {break;}

        }

        printf("%d\n",a[k]);

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: