您的位置:首页 > 其它

hdu1003 Max Sum (求连续子区间最大和)

2015-05-14 20:22 274 查看


Max Sum

                                                                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 169481    Accepted Submission(s): 39557

Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 

 
  
   解析:求连续子区间最大和。
               用f【i】表示以第 i 个数字结尾的连续子区间的最大值,则 f【i】=max{f【i-1】+a【i】,a【i】},然后分情况处理一下起点、终点,并更新当前最优值即可。

代码:
#include<cstdio>
#define inf 1000000000
#define maxn 1000
using namespace std;

int ans,ans_l,ans_r;

void work()
{
int i,j,k,n,x,sum,l,r;
scanf("%d",&n);
ans=-inf,sum=0,l=1,r=0;
for(i=1;i<=n;i++)
{
scanf("%d",&x);
if(sum<0)sum=x,l=r=i;
else sum+=x,r=i;

if(sum>ans)ans=sum,ans_l=l,ans_r=r;
}
printf("%d %d %d\n",ans,ans_l,ans_r);
}

int main()
{
freopen("1.in","r",stdin);
int t,i;
while(scanf("%d",&t)!=EOF)
for(i=1;i<=t;i++)
{
printf("Case %d:\n",i);
work();
if(i<t)printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: