您的位置:首页 > 其它

ACM-A Famous Music Composer

2015-05-14 18:25 239 查看
描述
Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:

A A#=Bb B C C#=DbD D#=Eb E F F#=Gb G G#=Ab
Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish
between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.
In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:

Ab minor A# majorA# minor C# major Db minor
D# major D# minorGb major Gb minor G# major
Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

输入Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).
输出For each case output the required answer, following the format of the sample.样例输入
Ab minor
D# major
G minor

样例输出
Case 1: G# minor
Case 2: Eb major
Case 3: UNIQUE


代码:

01.
#include<stdio.h>

02.
#include<stdlib.h>

03.
#include<string.h>

04.
int

main()

05.
{

06.
int

i,d=1,flag;

07.
char

a[1000];

08.
while
(
gets
(a))

09.
{

10.
flag=0;

11.
printf
(
"Case %d: "
,d);

12.
d++;

13.
if
(a[0]==
'A'
&&a[1]==
'b'
)
{ a[0]=
'G'
; a[1]=
'#'
;}

14.
else

if
(a[0]==
'A'
&&a[1]==
'#'
) { a[0]=
'B'
;
a[1]=
'b'
;}

15.
else

if
(a[0]==
'B'
&&a[1]==
'b'
) { a[0]=
'A'
;
a[1]=
'#'
;}

16.
else

if
(a[0]==
'C'
&&a[1]==
'#'
) { a[0]=
'D'
;
a[1]=
'b'
;}

17.
else

if
(a[0]==
'D'
&&a[1]==
'b'
) { a[0]=
'C'
;
a[1]=
'#'
;}

18.
else

if
(a[0]==
'D'
&&a[1]==
'#'
) { a[0]=
'E'
;
a[1]=
'b'
;}

19.
else

if
(a[0]==
'E'
&&a[1]==
'b'
) { a[0]=
'D'
;
a[1]=
'#'
;}

20.
else

if
(a[0]==
'G'
&&a[1]==
'b'
) { a[0]=
'F'
;
a[1]=
'#'
;}

21.
else

if
(a[0]==
'F'
&&a[1]==
'#'
) { a[0]=
'G'
;
a[1]=
'b'
;}

22.
else

if
(a[0]==
'G'
&&a[1]==
'#'
) { a[0]=
'A'
;
a[1]=
'b'
;}

23.
else

if
(a[0]==
'A'
&&a[1]==
'b'
) { a[0]=
'G'
;
a[1]=
'#'
;}

24.
else

flag=1;

25.

26.
if
(flag==0)
printf
(
"%s\n"
,a);

27.
else

printf
(
"UNIQUE\n"
);

28.
}

29.
}


这是一道细节题,大家仔细看了
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: