您的位置:首页 > 其它

POJ 1163 The Triangle

2015-05-14 12:43 302 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 39924Accepted: 24043
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output
30

Source

IOI 1994

题意就不多说了,数字三角形问题,基本动态规划。

f[ i ][ j ] 表示从位置(i,j)出发时的最大和,

则 f[i][j] += max(f[i + 1][j], f[i + 1][j + 1]);

代码1,递推计算:

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int f[110][110];
    int t;
    scanf("%d", &t);
    for(int i = 1; i <= t; i++) {
        for(int j = 1; j <= i; j++)
            scanf("%d", &f[i][j]);
    }
    for(int i = t - 1; i >= 1; i--) {   //往上走,从倒数第二层走到第一层
        for(int j = 1; j <= i; j++) 
            f[i][j] += max(f[i + 1][j], f[i + 1][j + 1]);   //状态转移
    }
    printf("%d\n", f[1][1]);
    return 0;
}


下面采用递归计算,同时把结果保存在 f 数组里,避免重复计算
代码2,记忆化搜索:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int f[110][110], a[110][110];
int t;
int d(int i, int j)
{
    if(f[i][j] > 0) return f[i][j]; //若已经计算过,则一定是最优解,返回即可,记忆化
    return f[i][j] = a[i][j] + (i == t ? 0 : max(d(i + 1, j), d(i + 1, j + 1)));//类似递推
}
int main()
{
    scanf("%d", &t);
    for(int i = 1; i <= t; i++) {
        for(int j = 1; j <= i; j++)
            scanf("%d", &a[i][j]);
    }
    memset(f, -1, sizeof(f));       //先初始化未计算
    d(1, 1);                        //递归搜索
    printf("%d\n", f[1][1]);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: