您的位置:首页 > 大数据 > 人工智能

POJ 2010 Moo University - Financial Aid (二分搜索)

2015-05-13 23:19 561 查看
Moo University - Financial Aid

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5758 Accepted: 1721
Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose
total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of
the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set
of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input
3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output
35


这个题比较6 Orz

不是很懂 大致思路是 二分中位数的位置  先按score排序记录id的位置 然后按aid排序 这样可以每次贪心的选取最小的aid 并同时保持id的位置

然后记录lef和rig的个数  如果lef<half 说明数小的 需要l = mid 如果rig < mid 说明数大了 r = mid 其他的情况说明可以 l = mid 同时记录ans

AC代码如下:

//
// Created by TaoSama on 2015-04-28
// Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, c, f, half;
struct Cow {
int id, s, f;
} sco
, aid
;

bool cmpByScore(const Cow& x, const Cow& y) {
return x.s < y.s;
}
bool cmpByAid(const Cow& x, const Cow& y) {
return x.f < y.f;
}

int main() {
#ifdef LOCAL
freopen("in.txt", "r", stdin);
// freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);

while(scanf("%d%d%d", &c, &n, &f) == 3) {
half = c >> 1;
for(int i = 1; i <= n; ++i)
scanf("%d%d", &sco[i].s, &sco[i].f);

sort(sco + 1, sco + 1 + n, cmpByScore);
for(int i = 1; i <= n; ++i) sco[i].id = i;
memcpy(aid + 1, sco + 1, sizeof(Cow) * n);
sort(aid + 1, aid + 1 + n, cmpByAid);

int l = 0, r = n + 1, ans;
while(l + 1 < r) {
int mid = l + r >> 1;

int lef = 0, rig = 0, sum = sco[mid].f;
for(int i = 1; i <= n; ++i) {
if(aid[i].id < mid && sum + aid[i].f <= f && lef < half)
sum += aid[i].f, ++lef;
if(aid[i].id > mid && sum + aid[i].f <= f && rig < half)
sum += aid[i].f, ++rig;
}
if(lef < half && rig < half) {
ans = -1;
break;
} else if(lef < half) l = mid;
else if(rig < half) r = mid;
else l = mid, ans = sco[mid].s;
}

printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: