您的位置:首页 > 其它

HDOJ 1002 A + B Problem II(大数A+B)

2015-05-13 22:27 369 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 253367    Accepted Submission(s): 48847


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

[align=left]Author[/align]
Ignatius.L

注:此题为:杭电ACM第1002题A + B Problem II(大数A+B)
说明:大数要开数组
已AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#define M 1000
using namespace std;
char ch1[M+10],ch2[M+10];
int a[M+10],b[M+10];
int main()
{
int T,cas=0;
cin>>T;
while(T--)
{
int len,len1,len2,i,j;
scanf("%s%s",ch1,ch2);
cout<<"Case "<<++cas<<":"<<endl;
cout<<ch1<<" + "<<ch2<<" = ";
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
len1=strlen(ch1);
len2=strlen(ch2);
len=len1>len2?len1:len2;
for(i=0,j=len1-1;i<len1;++i,--j)
a[j]=ch1[i]-'0';
for(i=0,j=len2-1;i<len2;++i,--j)
b[j]=ch2[i]-'0';
for(i=0;i<len;++i)
{
a[i]+=b[i];
if(a[i]>=10)
{
a[i+1]+=1;
a[i]-=10;
}
}
for(i=len+2;i>=0;--i)
if(a[i]!=0)
break;
for(;i>=0;--i)
cout<<a[i];
cout<<endl;
if(T!=0)
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息