您的位置:首页 > 其它

POJ 题目1905 Expanding Rods(二分,数学几何)

2015-05-13 18:50 387 查看
Expanding Rods

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 12827Accepted: 3311
Description


When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

Source
Waterloo local 2004.06.12 http://blog.csdn.net/lyy289065406/article/details/6648562 ac代码
#include<stdio.h>
#include<math.h>
const double eps=1e-5;
int main()
{
double l,n,c,s;
while(scanf("%lf%lf%lf",&l,&n,&c)!=EOF)
{
if(l<0&&n<0&&c<0)
break;
double low=0,high=0.5*l,mid;
s=(1+n*c)*l;
while(high-low>eps)
{
mid=(high+low)/2;
double r=(4*mid*mid+l*l)/(8*mid);
if(2*r*asin(l/(2*r))<s)
low=mid;
else
high=mid;
}
printf("%.3lf\n",mid);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: