您的位置:首页 > 其它

POJ 3579 Median (二分搜索)

2015-05-13 17:59 375 查看
Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4379 Accepted: 1340
Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N).
We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.

In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2

Sample Output
1
8


经典的二分套二分题目 每次二分a[i]+x的位置来确定有多少比它大的  然后确定它是不是中位数

AC代码如下:

//
// Created by TaoSama on 2015-04-28
// Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, a
;
long long half;

bool check(int x) {
int cnt = 0;
for(int i = 1; i <= n; ++i)
cnt += a + n - lower_bound(a + 1, a + 1 + n, a[i] + x) + 1;
return cnt > half;
}

int main() {
#ifdef LOCAL
freopen("in.txt", "r", stdin);
// freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);

while(scanf("%d", &n) == 1) {
for(int i = 1; i <= n; ++i) scanf("%d", a + i);
sort(a + 1, a + 1 + n);

half = n * (n - 1LL) >> 2;
int l = 0, r = 1e9;
while(l + 1 < r) {
int mid = l + r >> 1;
if(check(mid)) l = mid;
else r = mid;
}
printf("%d\n", l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: