您的位置:首页 > 其它

BestCoder Round #40 1001——精度——Tom and paper

2015-05-09 21:43 302 查看
Problem Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. T≤10,n≤109

Output

For each case, output a integer, indicates the answer.

Sample Input

3
2
7
12


Sample Output

6
16
14

大意:给你一个n表示一个纸片的面积,长和宽都是整数,问你最小的纸片的周长

orz对于精度水题好讨厌的感觉,,

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int n;
int T;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
int ans = 2*(n+1);
for(int i = 1; i*i <=n;i++){
if(n % i == 0)
ans = min(ans,2*(i + n/i));
}
printf("%d\n",ans);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: