您的位置:首页 > 编程语言 > C语言/C++

Single Round Match

2015-05-09 14:43 357 查看
Single Round Match

(Input File: single.in / Standard Output)

Association for Couples Match (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is “Singles Day”, on this day, ACM invites a large group of singles to the party. People round together, chatting with others, and matching partners.

There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divide people into 11 groups, each group should have the same amount of couples and no people are left without the groups.

Can ACM achieve the goal?

Input:

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0<=N, M<=101000), which are the amount of

gentlemen and ladies.

Output:

For each test case, output “YES” if it is possible to find a way, output “NO” if not.

Sample Input:

3

1 1

11 11

22 11

Sample Output:

NO

YES

NO

与能否被11整除的题结合起来的题。。。

AC代码:

#include <iostream>
#include <cstring>
using namespace std;
int fun(char* p)
{
int i=0;
long long sum=0;
while (p[i]!='\0')
{
if(i&1)
sum+=-(p[i]-'0');
else
sum+=p[i]-'0';
i++;
}
if (sum%11==0)return 1;
return 0;
}
int main()
{
int N;
char n[1001],m[1001];
cin >> N;

while (N--)
{
cin >> n >> m;
if (strcmp(n,m)==0&&fun(m))
{
cout << "YES" << endl;
}
else
{
cout << "NO" << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++