您的位置:首页 > 其它

HDU 1800 Flying to the Mars(字典树)

2015-05-08 23:39 330 查看

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12767 Accepted Submission(s): 4048



Problem Description


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF
convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got
wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that
is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student
is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the
broomstick needed .

For example :

There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;

One method :

C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.

D could teach E;So D E are eligible to study on the same broomstick;

Using this method , we need 2 broomsticks.

Another method:

D could teach A; So A D are eligible to study on the same broomstick.

C could teach B; So B C are eligible to study on the same broomstick.

E with no teacher or student are eligible to study on one broomstick.

Using the method ,we need 3 broomsticks.

……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.



Input
Input file contains multiple test cases.

In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)

Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);



Output
For each case, output the minimum number of broomsticks on a single line.


Sample Input
4
10
20
30
04
5
2
3
4
3
4




Sample Output
1
2




Author
PPF@JLU


Recommend
题意:求数列中出现最多的数的个数,但是需要之一的是熟的长度有30,以前居然int水过,现在用字典树写了一遍

需要注意的是要删除内存,不然会超的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i < b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 10

struct stud{
  int num;
  stud * next
;
  //void he(){num=0;for(int i=0;i<N;i++) next[i]=NULL;}
}*root;

int ans;

void insert(char *c)
{
	stud *p=root;

	while(*c)
	{
		if(p->next[*c-'0']==NULL)
			{
				stud *t=(stud *)malloc(sizeof(stud));
				for(int i=0;i<N;i++)
					t->next[i]=NULL;
				t->num=0;
			    p->next[*c-'0']=t;
			    p=t;
			}
        else p=p->next[*c-'0'];
	 c++;
	}
    p->num++;
    ans=max(p->num,ans);
}

void delet(stud* temp)
{
     int i;
     if(temp==NULL) return ;
     for(i=0;i<N;i++)
		if(temp->next[i]!=NULL)
		  delet(temp->next[i]);
	 delete(temp);
}

int main()
{
   int i,j;
   char ch[35];
   int n;
   while(~scanf("%d",&n))
   {
   	 root=(stud *)malloc(sizeof(stud));
   	 for(i=0;i<N;i++)
		root->next[i]=NULL;
	root->num=0;
	ans=0;
	 while(n--)
	 {
	 	scanf("%s",ch);
	 	for(i=0;ch[i];i++)
			if(ch[i]!='0') break;
		insert(ch+i);
	 }
      printf("%d\n",ans);
      delet(root);
   }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: