您的位置:首页 > 其它

UVa 2038 - Strategic game(二分图最小顶点覆盖 or 树形DP)

2015-05-08 21:12 603 查看
Strategic game

Description



Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which
form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:



the solution is one soldier (at the node 1).

Input
The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format:

node_identifier:(number_of_roads) node_identifier1 node_identifier2 � node_identifiernumber_of_roads

or

node_identifier:(0)

The node identifiers are integer numbers between
0 and n-1, for n nodes ( 0 < n ≤ 1500). Every edge appears only once in the input data.

Output
The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output
12


题意:给定一棵树,选择尽量少的点,使得每个没有选中的结点至少和一个已经选中的结点相邻。输出最少需要选择的节点数。

思路:经典的二分图最小顶点覆盖, 也是经典的树形 DP 。

最小顶点覆盖 == 最大匹配(双向图)/2

数据较大,用邻接表。不然会超时。

<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;

const int MAXN = 1510;
int nx, ny;
int used[MAXN];
int cx[MAXN], cy[MAXN];
vector<int>g[MAXN];

int Find(int u)
{
for(int i = 0; i < g[u].size(); i++)
{
int v = g[u][i];
if(!used[v])
{
used[v] = 1;
if(cy[v]==-1 || Find(cy[v]))
{
cy[v] = u;
cx[u] = v;
return 1;
}
}
}
return 0;
}

int Hungary()
{
int res = 0;
memset(cx, -1, sizeof(cx));
memset(cy, -1, sizeof(cy));
for(int i = 0; i < nx; i++)
{
if(cx[i] == -1)
{
memset(used, 0, sizeof(used));
if(Find(i))
res++;
}
}
return res;
}

int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int t, n, num;
int x, y;
while(cin>>n)
{
if(!n)
break;
ny = nx = n;
t = n;
for(int i = 0; i < n; i++)
g[i].clear();
while(t--)
{
scanf("%d:(%d)", &x, &num);
while(num--)
{
scanf("%d", &y);
g[x].push_back(y);
g[y].push_back(x);
}
}
printf("%d\n", Hungary()/2);
}
return 0;
}</span>


树形DP解法:

dp[u][0]: 表示不选 i 结点,覆盖这个子树所需的最少点

dp[u][1]:表示选 i 结点,覆盖这个子树所需的最少点

状态转移方程:

u 到 v 有一条无向边,v 是 u 的子结点

dp[u][1] = sum{ min{dp[u][0],
dp[u][1] }

dp[u][0] = sum{
dp[u][1] }

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;

const int MAXN = 1510;
int nx, ny;
int vis[MAXN];
int cx[MAXN], cy[MAXN];
vector<int>g[MAXN];
int dp[MAXN][MAXN];

void dfs(int u)
{
vis[u] = 1;
dp[u][0] = 0;
dp[u][1] = 1;
for(int j = 0; j < g[u].size(); j++)
{
int v = g[u][j];
if(!vis[v])
{
dfs(v);
dp[u][0] += dp[v][1];
dp[u][1] += min(dp[v][0], dp[v][1]);
}
}
}

int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int t, n, num;
int x, y;
while(cin>>n)
{
if(!n)
break;
ny = nx = n;
t = n;
for(int i = 0; i < n; i++)
g[i].clear();
while(t--)
{
scanf("%d:(%d)", &x, &num);
while(num--)
{
scanf("%d", &y);
g[x].push_back(y);
g[y].push_back(x);
}
}
memset(dp, 0, sizeof(dp));
memset(vis, 0, sizeof(vis));
dfs(0);
printf("%d\n", min(dp[0][0], dp[0][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: