您的位置:首页 > 其它

poj2453 an easy problem (位运算)

2015-05-08 20:50 363 查看
An Easy Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7996 Accepted: 4778
Description

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form. 

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I. 

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".
Input

One integer per line, which is I (1 <= I <= 1000000). 

A line containing a number "0" terminates input, and this line need not be processed.
Output

One integer per line, which is J.
Sample Input
1
2
3
4
78
0

Sample Output
2
4
5
8
83

Source
POJ Monthly,zby03

解析:http://blog.csdn.net/w57w57w57/article/details/6657547
代码:

#include<cstdio>
using namespace std;

void init()
{
freopen("poj2453.in","r",stdin);
freopen("poj2453.out","w",stdout);
}

void work()
{
int n,ans,t,x;
while(scanf("%d",&n)&&n)
{
x=n&(-n),t=n+x;
ans=t|((n^t)/x)>>2;
printf("%d\n",ans);
}
}

int main()
{
init();
work();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: