您的位置:首页 > 其它

POJ_1564 Sum It Up(DFS)

2015-05-08 20:11 375 查看
Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , … , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , … , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing
Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line
NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1

5 3 2 1 1

400 12 50 50 50 50 50 50 25 25 25 25 25 25

0 0

Sample Output

Sums of 4:

4

3+1

2+2

2+1+1

Sums of 5:

NONE

Sums of 400:

50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25

题目解析:

有一行数字按递减排列,求出所有的组合使数字和为某一个固定值。安照排列顺序从第一个数往后DFS,直到能满足条件。每一次的pos表示当前选择第几位,所以要注意对于该位的数字如果在数列中后一位与前一位相同,就不能计算,否则会重复。

代码实现:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 1000002
using namespace std;

int T,N;
int sx;
int Times;
int num[MAX];
int save[MAX];
void dfs(int x,int y);
void print();

int main()
{
while( scanf("%d%d",&T,&N) )
{
if( T == 0 && N == 0 )
break;
Times = 0; sx = 0;
memset(num,0,sizeof(num));
for( int i = 0; i < N; i++ )
scanf("%d",&num[i]);
cout<<"Sums of "<<T<<':'<<endl;
for( int i = 0; i < N; i++ )
{
if( i != 0 && num[i] == num[i-1] )
continue ;
save[sx] = num[i];
sx++;
dfs(i,num[i]);
sx--;
save[sx]=0;
}
if( Times == 0 )
cout<<"NONE"<<endl;
}
return 0;
}

void dfs(int pos,int sum)
{
if( sum >= T )
{
if( sum == T )
{
Times++;
print();
}
return ;
}
for( int i = pos+1 ; i < N; i++ )
{
if( i-1 != pos && num[i] == num[i-1] )
continue ;
save[sx] = num[i];
sx++;
dfs(i,sum+num[i]);
sx--;
save[sx]=0;
}
return ;
}

void print()
{
for( int i = 0; i < sx; i++ )
{
cout<<save[i];
if( i != sx-1 )
cout<<'+';
else
cout<<endl;
}
return ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs