您的位置:首页 > 运维架构

POJ - 1094 Sorting It All Out [ topo]

2015-05-07 01:08 295 查看
Sorting It All Out

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and
C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will
be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters:
an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.

Sorted sequence cannot be determined.

Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0


Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


题目分析:每读入一个,进行一次topo;
代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<queue>
using namespace std;

int n,m;
int vis[30],vis_[30],num;
int ind[30],ind_[30];
int has[30][30];
vector<int> E[30];
vector<int> s;

int topo()
{
s.clear();
queue<int> que;
for(int i=0;i<n;i++) ind_[i]=ind[i];
int cnt=0,pos;
for(int j=0;j<n;j++){
if(vis[j]&&ind_[j]==0){
que.push(j);
cnt++;
}
}
int ret=0;
while(!que.empty()){
if(cnt!=1) ret=2;
int u=que.front();
s.push_back(u);
que.pop();cnt--;
for(int i=0;i<E[u].size();i++){
int v=E[u][i];
ind_[v]--;
if(!ind_[v]){
que.push(v);
cnt++;
}
}
}
if(s.size()<num) return 3;
if(ret!=2&&s.size()==n) return 1;
else
return 2;
}

int main()
{
while(scanf("%d%d",&n,&m)==2,n+m)
{
char op[20];
memset(vis,0,sizeof vis);
memset(ind,0,sizeof ind);
memset(has,0,sizeof has);
num=0;
for(int i=0;i<n;i++) E[i].clear();
int ans=2,end_;
for(int i=1;i<=m;i++)
{
scanf("%s",op);
if(has[op[0]-'A'][op[2]-'A']) continue;
has[op[0]-'A'][op[2]-'A']=1;
if(vis[op[0]-'A']==0){
vis[op[0]-'A']=1;
num++;
}
if(vis[op[2]-'A']==0){
vis[op[2]-'A']=1;
num++;
}
E[op[0]-'A'].push_back(op[2]-'A');
ind[op[2]-'A']++;
if(ans==2){
ans=topo();
end_=i;
}
}
if(ans==1){
printf("Sorted sequence determined after %d relations: ",end_);
for(int i=0;i<s.size();i++)
printf("%c",s[i]+'A');
printf(".\n");
}
else if(ans==2) printf("Sorted sequence cannot be determined.\n");
else printf("Inconsistency found after %d relations.\n",end_);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: