您的位置:首页 > 其它

poj 3186 Treats for the Cows(区间dp)

2015-05-06 19:55 387 查看
Treats for the Cows

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4375Accepted: 2226
Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2

Sample Output
43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

题目要求从两边取,权值为a[i]*cnt,这样就很不好处理。

假设从里面往外取,取最里面的那个权值为a[i]*n,倒数第二个为a[j]*(n-1),

dp[i][j]表示取完[i,j]区间的最大值,那么由dp[i][i]很容易得到dp[i][i+1];

dp[i][j]=max(dp[i+1][j]+a[i]*cnt,dp[i][j-1]+a[j]*cnt); (cnt为第几次取数字)

最终答案就是dp[1]
;

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
using namespace std;
#define ll long long
#define mem(a,t) memset(a,t,sizeof(a))
#define N 2005
const int M=100005;
const int inf=0x1f1f1f1f;
int a
,dp

;
int main()
{
int i,j,k,n;
while(~scanf("%d",&n))
{
mem(dp,0);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);     //从里向外逆推区间
dp[i][i]=a[i]*n;    //最后取的是a[i]
}
for(k=1;k<n;k++) //区间长度为k+1时
{
for(i=1;i+k<=n;i++)      //枚举区间长度为k+1的每个区间起点
{
j=i+k;               //该区间终点为j=i+k
dp[i][j]=max(dp[i+1][j]+a[i]*(n-k),dp[i][j-1]+a[j]*(n-k));
}            //该区间的最优解为先取左边或者右边两者的最大值
}
printf("%d\n",dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: