您的位置:首页 > 其它

Same binary weight

2015-05-05 21:38 218 查看


Same binary weight

时间限制:300 ms | 内存限制:65535 KB
难度:3

描述

The binary weight of a positive integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer
N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入The input has multicases and each case contains a integer N.

输出For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555


样例输出
1718
8
11
17
555557


来源topcoder
上传者
骆魁永

参考思想网址:http://www.cnblogs.com/yewei/archive/2012/09/21/2696499.html

参考代码:讨论区里

刚开始做的超时了。现在知道一个方法就是把数对应的二进制位,从右往左,找到第一个“01” 变为“10”,然后此“01”串后面的‘1’都放到后面。

我看到其他博客写的按位运算,我看不懂,水平还太次。看到讨论区里的一个大神的代码,第一次接触了.#include<bitset> 感觉这个库文件好棒。

#include <iostream>//<span style="color: rgb(113, 32, 21); font-family: Tahoma, Arial, sans-serif, simsun; font-size: 16px; "><strong>超时代码:</strong></span>
#include<bitset>
#include<string>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
bitset<32> bitint(n);
string s=bitint.to_string();
int pos=s.rfind("01");
swap(s[pos],s[pos+1]);
if(pos+2<31)
sort(s.begin()+pos+2,s.end());
cout<<bitset<32>(s).to_ulong()<<endl;
}
return 0;
}


#include<iostream>
#include<stdio.h>
using namespace std;
int diaoyong(int n)
{
int k=0;
int count=0;
while(n!=0)
{
if(n%2==1)
count++;
n=n/2;
}
return count;
}
int main()
{
int n,count;
while(scanf("%d",&n)!=EOF)
{
count=diaoyong(n);
while(++n)
{
if(count==diaoyong(n))
{
cout<<n<<endl;
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: