您的位置:首页 > 其它

POJ 1287 Networking (最小生成树入门)

2015-05-03 11:42 387 查看
POJ 1287 Networking (最小生成树入门)
强调内容


题目:

Networking

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 6698 Accepted: 3648

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3

1 2 37

2 1 17

1 2 68

3 7

1 2 19

2 3 11

3 1 7

1 3 5

2 3 89

3 1 91

1 2 32

5 7

1 2 5

2 3 7

2 4 8

4 5 11

3 5 10

1 5 6

4 2 12

0

Sample Output

0

17

16

26

Source

”’

在平面上给你P个点n个线段,每个点之间可能有多线段或者没有咸蛋,将平面上的点全部连起来的最短线段总长。

上次集训的时候一个很nice的师哥和我们讲过这题,时间过了几个月,又没怎么写,就忘记了怎么实现了,但还好基本思路还是很清晰的,然后就随便写了出来下面这个东西

# include<iostream>
# include<cstdio>
# include<cstring>

using namespace std;
const int inf=0x3f3f3f3f;
int a[52][52],len,vis[55],p;
int prim();

int main()
{
int r,i,j,temp;
while(1)
{
scanf("%d",&p);
if(p==0)
break;
scanf("%d",&r);

for(i=1;i<=p;i++)
for(j=1;j<=p;j++)
a[i][j]=inf;
memset(vis,0,sizeof(vis));
len=0;

while(r--)
{
scanf(" %d %d %d",&i,&j,&temp);
if(temp<a[i][j])
a[i][j]=a[j][i]=temp;
}
vis[1]=1;
printf("%d\n",prim());
}
return 0;

}

int prim()
{
int i,j,k,j_m,temp,ans;
for(k=1;k<p;k++)
{
temp=inf, ans=0;
for(i=1;i<=p;i++)
{
if(!vis[i])
continue;
for(j=1;j<=p;j++)
if(!vis[j] && a[i][j]!=inf && temp>a[i][j])
temp=a[i][j],  j_m=j;
}
len+=temp, vis[j_m]=1;
}
return len;
}


写完之后上网看看别人的实现,发现是这么写的

# include<iostream>
# include<cstdio>
# include<cstring>

using namespace std;
const int inf=0x3f3f3f3f;
int a[52][52],len,vis[55],dist[55],p;
int prim();

int main()
{
int r,i,j,temp;
while(1)
{
scanf("%d",&p);
if(p==0)
break;
scanf("%d",&r);

for(i=1;i<=p;i++)
for(j=1;j<=p;j++)
a[i][j]=inf;
memset(vis,0,sizeof(vis));
len=0;

while(r--)
{
scanf(" %d %d %d",&i,&j,&temp);
if(temp<a[i][j])
a[i][j]=a[j][i]=temp;
}
vis[1]=1;
printf("%d\n",prim());
}
return 0;

}

int prim()
{
int i,j,k,j_m,i_m,temp;
for(i=1;i<=p;i++)
dist[i]=a[i][1];

for(k=1;k<p;k++)
{
temp=inf;
for(i=1;i<=p;i++)
if(!vis[i] && temp>dist[i])
i_m=i,temp=dist[i];

vis[i_m]=1,len+=temp;

for(j=1;j<=p;j++)
if(!vis[i] && dist[j]>a[i_m][j])
dist[j]=a[i_m][j];
}
return len;
}


感觉第二种写法的时间复杂度小一点
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: