您的位置:首页 > 其它

HDU 2069 Coin Change

2015-05-02 22:01 302 查看
Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15098 Accepted Submission(s): 5108

Problem Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11

26

Sample Output

4

13

这道题对硬币的数量有限制!不能用母函数

#include <iostream>
#include <cstdio>
#include <memory.h>
using namespace std;
int main(void)
{
int n;
while(scanf("%d",&n)!=EOF)
{
int sum=0;
for(int i=0;i<=n/50;i++)
{
for(int j=0;j<=n/25;j++)
{
for(int k=0;k<=n/10;k++)
{
for(int l=0;l<=n/5;l++)
{
for(int m=0;m<=n;m++)
{
if((i*50+j*25+k*10+l*5+m)==n&&(i+j+k+l+m)<=100)
{
sum++;
}
}
}
}
}
}
printf("%d\n",sum);
}

return 0;
}

/*母函数不行了,题中要求硬币的数量不能超过100个
int a[300],b[300];

void mother(int i,int num,int n)
{//i代表第i个元素,第i个元素的数量有num个,需要计算的最大指数n
for(int j=0;j<=n;j++)
for(int k=0;k<=num&&k*i+j<=n;k++)
b[k*i+j]+=a[j];
for(int j=0;j<=n;j++)
{
a[j]=b[j];
b[j]=0;
}
}

int main(void)
{
int n;
while(scanf("%d",&n)!=EOF)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
int c1[6]={1,5,10,25,50};
// for(int i=0;i<5;i++)
//   printf("%d\n",c1[i]);
a[0]=1;
for(int i=0;i<5;i++)
mother(c1[i],n,n);
if(a
>100) printf("100\n");
else
printf("%d\n",a
);

}

return 0;
}*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: