您的位置:首页 > 其它

POJ 3280 Cheapest Palindrome

2015-05-02 09:59 351 查看
Cheapest Palindrome

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 6526 Accepted: 3166

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different
IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some
other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string
longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or
deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs
can be added to a string.

Input

Line 1: Two space-separated integers: N and M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4

abcb

a 1000 1100

b 350 700

c 200 800

Sample Output

900

区间DP。。

上一次提交的时候,少考虑一种情况,就WA了,原因是没有考虑到首字母和尾字母相等的情况下,这样的情况下,DP[i][j]的最小花费就是DP[i+1][j-1]了。

如果首字母和尾字母不相同,就比较对首字母处理的花费和对尾字母处理的花费,选择花费少的那一个。。。。。

DP[i][j]表示的是 从字符串i位置下标到j位置下标的区间变成回文字符串的时候,需要的花费最少是多少。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <memory.h>
using namespace std;
char s[2500];
int cost[30];
int dp[3000][3000];
int main(void)
{
// freopen("H.txt","r",stdin);
int n,m;
while( scanf("%d%d",&n,&m)!=EOF)
{
getchar();
scanf("%s",s);
for(int i=1;i<=n;i++)
{
getchar();
int add,del;
char c;
scanf("%c%d%d",&c,&add,&del);
cost[c-'a']=min(add,del);
}
memset(dp,0,sizeof(dp));
for(int k=1;k<m;k++)
{
for(int i=0,j=k;j<m;i++,j++)
{
if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1];
else
dp[i][j]=min(dp[i][j-1]+cost[s[j]-'a'],dp[i+1][j]+cost[s[i]-'a']);
}
}
printf("%d\n",dp[0][m-1]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: