您的位置:首页 > 其它

Radar Installation - POJ 1328 贪心

2015-05-01 22:24 363 查看
Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58694 Accepted: 13213
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 


 

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1


题意:每个雷达能监控距离为d的区域,在坐标平面上有若干个小岛,问最少要用多少个雷达才能监控所有的小岛。如果不能监控所有的小岛,输出-1

思路,每个小岛给出坐标后,雷达的可能区域在x轴上对应一个线段,所求的便是最少有多少个点可以使每条线段都至少覆盖一个点。先对线段的起始点进行升序排序,每次遍历检查是否与之前的区间有交集,有的话对区域求交,没有的话cnt++并记录新的区间。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#define MAXN 1010
using namespace std;
struct node
{
double s,e;
}island[MAXN];
bool cmp (node a, node b)
{
if(a.s==b.s) return a.e>b.e;
else
return a.s<b.s;
}
int main(){
// freopen("in.txt","r",stdin);
int n,dd,kas=0;
double d,ss;
while(scanf("%d%d",&n,&dd),n||dd){
d=dd;
int cnt=1;
double x,y;
for(int i=1;i<=n;i++){
scanf("%lf%lf",&x,&y);
if(fabs(y)>d) cnt=-1;
island[i].s=x-sqrt(d*d-y*y);
island[i].e=x+sqrt(d*d-y*y);
}
sort(island+1,island+1+n,cmp);
double l=island[1].s,r=island[1].e;
if(cnt!=-1)
for(int i=2;i<=n;i++){
if(island[i].s>r){
cnt++;
l=island[i].s;
r=island[i].e;
}else {
l=max(l,island[i].s);
r=min(r,island[i].e);
}

}
printf("Case %d: %d\n",++kas,cnt);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: