您的位置:首页 > 其它

HDOJ 题目3449 Consumer(背包)

2015-04-30 23:58 232 查看


Consumer

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/65536 K (Java/Others)

Total Submission(s): 1435 Accepted Submission(s): 752



Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy
the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number
goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output

For each test case, output the maximum value FJ can get

Sample Input

3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60


Sample Output

210


Source

2010 ACM-ICPC Multi-University
Training Contest(2)——Host by BUPT

Recommend

We have carefully selected several similar problems for you: 3535 2415 3443 3450 3448

每组物品加入了箱子的限制,如果要买改组物品,就必须先买箱子

考虑第i组物品时,前i-1组的最优值已经知道,假设总容量为V,改组的箱子的代价为p,那么如果我们要买该组物品,可用容量就只有V-p,所以,我们先用tmp数组记录前i-1阶段容量范围在[0,V-p]这个范围内的最优值,对应加上箱子的代价p的[p,V]这个区间,然后在这个范围内对改组物品做01背包,再去更新dp值

ac代码

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
__int64 dp[100010],n,m,temp[100010];
int main()
{
while(scanf("%I64d%I64d",&n,&m)!=EOF)
{
int i,j,k,vv,cnt;
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
scanf("%d%d",&vv,&cnt);
for(j=0;j+vv<=m;j++)
{
temp[j+vv]=dp[j];
}
for(j=1;j<=cnt;j++)
{
int w,v;
scanf("%d%d",&w,&v);
for(k=m;k>=w+vv;k--)
temp[k]=max(temp[k],temp[k-w]+v);
}
for(j=vv;j<=m;j++)
dp[j]=max(dp[j],temp[j]);
}
printf("%I64d\n",dp[m]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: