您的位置:首页 > 理论基础 > 计算机网络

2014西安赛区网络赛

2015-04-30 23:01 351 查看
A - Post Robot
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.

But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to
read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.

After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will
make a comment “MAI MAI MAI!”, and go on reading the post.

In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.



Input

A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters
are case sensitive.

The size of the article does not exceed 8KB.


Output

Output should contains comments generated by your script, one per line.


Sample Input

Apple bananaiPad lemon ApplepiSony
233
Tim cook is doubi from Apple
iPhoneipad
iPhone30 is so biiiiiiig Microsoft
makes good App.




Sample Output

MAI MAI MAI!
MAI MAI MAI!
MAI MAI MAI!
SONY DAFA IS GOOD!
MAI MAI MAI!
MAI MAI MAI!
MAI MAI MAI!




AC code:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstdio>
#include<queue>
#include<map>
#include<vector>
using namespace std;
int main()
{
    string s;
    while(cin>>s)
    {

        int len=s.length();
        string s1,s2,s3;
        for(int i=0;i<len;i++)
        {
            s1=s.substr(i,4);
            if(s1=="iPod"||s1=="iPad")
                printf("MAI MAI MAI!\n");
            else if(s1=="Sony")
                printf("SONY DAFA IS GOOD!\n");
            s2=s.substr(i,5);
            if(s2=="Apple")
                printf("MAI MAI MAI!\n");
            s3=s.substr(i,6);
            if(s3=="iPhone")
                printf("MAI MAI MAI!\n");
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: