您的位置:首页 > 产品设计 > UI/UE

Children’s Queue - HDU 1297 简单DP

2015-04-29 17:54 330 查看



Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11915    Accepted Submission(s): 3874


Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side.
The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

 

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

 

Sample Input

1
2
3

 

Sample Output

1
2
4

题意:n个同学站队,女生不能落单,问有多少种排列方案

思路:dp[i][1]表示第i位是男生的方案数,dp[i][0]表示第i位是女生的方案数,转移方程为

dp[i][1]=dp[i-1][1]+dp[i-1][0];
dp[i][0]=dp[i-2][1]+dp[i-1][0];

Hint:注意数据范围,要用高精度,求方便直接用了Java的BigInteger

import java.util.Scanner;
import java.math.*;

public class HDU1297 {

public static void main(String[] args) {
int n;
BigInteger dp[][]=new BigInteger [1010][2];
dp[1][1]=new BigInteger("1");
dp[1][0]=new BigInteger("0");
dp[2][1]=new BigInteger("1");
dp[2][0]=new BigInteger("1");
for(int i=3;i<=1000;i++)
{
dp[i][1]=dp[i-1][1].add(dp[i-1][0]);
dp[i][0]=dp[i-2][1].add(dp[i-1][0]);
}
Scanner in=new Scanner(System.in);
while(in.hasNext())
{
n=in.nextInt();
System.out.println(dp
[1].add(dp
[0]));
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: