您的位置:首页 > 其它

poj 2386 Lake Counting

2015-04-29 14:26 405 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 22612Accepted: 11402
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

搜索标记了某W之后不用再恢复,表示搜索过,不用再搜了。

#include<stdio.h>
#include<string.h>
char map[105][105];
int direction[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
void dfs(int x,int y)
{
map[x][y]='.';
int i;
for(i=0;i<8;i++)
{
if(map[x+direction[i][0]][y+direction[i][1]]=='W')
dfs(x+direction[i][0],y+direction[i][1]);
}
}
int main()
{
int hang,lie;
scanf("%d %d",&hang,&lie);
int i,j,cnt=0;
for(i=0;i<hang;i++)
{
scanf("%s",&map[i]);
}
for(i=0;i<hang;i++)
{
for(j=0;j<lie;j++)
{
if(map[i][j]=='W')
{
cnt++;
dfs(i,j);
}
}
}
printf("%d\n",cnt);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: