您的位置:首页 > 其它

UVA202循环小数Repeating Decimals

2015-04-28 13:23 501 查看
Repeating Decimals

The decimal expansion of the fraction 1/33 is , where the is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.

Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle.

In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins - it will begin within the first 50 places - and place ``...)" after the 50th digit.

Print a blank line after every test case.

Sample Input

76 25
5 43
1 397

Sample Output

76/25 = 3.04(0)
1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle



题意:

当a除以b.有一个结论:正整数a/整数b的结果,小数部分总是有限小数或无限循环小数。本题:如果有循环小数,用()标记出来,同时计算出循环小数的长度;如果没有,结尾用(0)表示

解题思路:

1. 鸽巢原理的应用(或者抽屉原则)即:桌上有十个苹果,要把这十个苹果放到九个抽屉里,那么每个抽屉代表一个集合,每一个苹果可以代表一个元素,假如有n+1个元素放到n个集合中去,其中必定至少有一个集合里有两个元素。

应用在本题中,a/b,那么根据模运算,可以知道,余数必定在0~b-1范围,那么当运算第b+1次时,必定重复一个余数(根据鸽巢原理)。当找到开始重复的余数时,即可找到循环节。

2. 用q[MAX]记录每次运算的商,r[MAX]记录每次运算的余数,同时用设置标记数组vist[MAX],标记余数是否出现过

比如5/7 q[0]~q[6]数组依次0 7 1 4 2 8 5; r[0]~r[6]依次为5 5 1 3 2 6 4



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAX = 3000;
int y[MAX];  //数组 存储 余数
int s[MAX];  //数组 存储 商
int bj[MAX];  //标记 数字i 是否出现

int main()
{
int a, b;

while (cin >> a >> b)
{
memset(y, 0, sizeof(y));
memset(s, 0, sizeof(s));
memset(bj, 0, sizeof(bj));

int a_temp = a;             //保存a的值
int cnt = 0;                //
s[cnt++] = a / b;              //存ab相除的 商(整数部分)
a = a%b;                    //求ab相除的余数
while (a&&!bj[a])   //a不为0 &&  a在标记数组没有出现过
{
bj[a] = 1;              //标记 余数a
s[cnt] = 10 * a / b;        //循环存 商
y[cnt] = a;            //循环 存 余数
a = 10 * a%b;
cnt++;              //最后一次循环时,cnt已经多加了一次。
}
cout << a_temp << "/" << b << "=" << s[0] << ".";

if (a == 0)
{
for (int i = 1; i<cnt; i++)
cout << s[i];
cout << "(0)" << endl;
cout << "1=number of digits in repeating cycle" << endl;

}
else
{
int pos;
for (int i = 1; i <= 50 && i<cnt; i++)
{
if (y[i] == a)      //找到数值a在余数数组的位置
{
cout << "(";
pos = i;
}
cout << s[i];    //循环输出 循环部分的 数字
}
if (cnt>50)
cout << "....)" << endl;
else
cout << ")" << endl;
cout << cnt - pos << "=number of digits in repeating cycle" << endl;

}

}
getchar();
getchar();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: