您的位置:首页 > 其它

nyoj 349&Poj 1094 Sorting It All Out——————【拓扑应用】

2015-04-28 10:19 309 查看

Sorting It All Out

时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

输入Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.输出For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

样例输入
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

样例输出
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题目大意:给你n个点,给你m条边代表大小关系。问你在第几条边加入后有矛盾(有环)或能确定关系,或者不能确定关系。
解题思路:首先每次加入一条边,就用floyd传递闭包,之后再判断是否形成环。如果没有环,就判断是否能确定唯一大小关系,这里有一个重要的判断条件即如果所有的结点的度等于n-1,则拓扑排序记录路径。


#include<bits/stdc++.h>
using namespace std;
int Map[50][50],indegree[50],outdegree[50];
char S_ord[50];
bool floyd(int n){
for(int k=0;k<n;k++){   //传递闭包
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(Map[i][k]&&Map[k][j])
Map[i][j]=1;
}
}
}
for(int i=0;i<n;i++)    //判断是否形成环
if(Map[i][i])
return 1;
return 0;
}
bool calcu_is_ord(int n){  //计算目前是否有序
memset(indegree,0,sizeof(indegree));
memset(outdegree,0,sizeof(outdegree));
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(Map[i][j]){
indegree[j]++;
outdegree[i]++;
}
}
}
for(int i=0;i<n;i++){
if(indegree[i]+outdegree[i]!=n-1){
/*如果所有结点都满足入度加出度等于结点总数减一,说明已经有序。因为如果有序,必然
会有入度为0~n-1,相应的出度为n-1~0。所以只要所有的结点度都为n-1,则说明已经有序。
*/
return 0;
}
}
return 1;
}
void topo_sort(int n){  //拓扑排序求大小顺序
int que_[50],vis[50],top=0,cnt=0,u;
for(int i=0;i<n;i++){
if(indegree[i]==0){
que_[++top]=i;
}
}
memset(vis,0,sizeof(vis));
while(top){
u=que_[top--];
vis[u]=1;
S_ord[cnt++]=u+'A';
for(int i=0;i<n;i++){
if(!vis[i]&&Map[u][i]){
indegree[i]--;
}
if(!vis[i]&&indegree[i]==0){
que_[++top]=i;
}
}
}
S_ord[cnt++]='\0';
}
int main(){
int n,m;
char str[10];
while(scanf("%d%d",&n,&m)!=EOF&&(n+m)){
memset(Map,0,sizeof(Map));
int flag_cir=0,flag_ord=0;  //记录在第几组关系输入时形成环或有序
for(int i=1;i<=m;i++){
scanf("%s",str);
Map[str[0]-'A'][str[2]-'A']=1;
if(flag_cir||flag_ord)
continue;
if(floyd(n)){ flag_cir=i;continue;}
else if(calcu_is_ord(n)){topo_sort(n);flag_ord=i;continue;}
}
if(flag_cir)
printf("Inconsistency found after %d relations.\n",flag_cir);
else if(flag_ord){
printf("Sorted sequence determined after %d relations: %s.\n",flag_ord,S_ord);
}else{
printf("Sorted sequence cannot be determined.\n");
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: