您的位置:首页 > 其它

ZOJ3870 Team Formation(2015浙江省赛) 位运算异或

2015-04-27 22:28 204 查看
Team Formation

Time Limit: 3 Seconds
Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from
N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level
A and B form a team, the skill level of the team will be
A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.
A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains
N positive integers separated by spaces. The ith integer denotes the skill level of
ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

省赛时候的题目,当时做不出来,看了别人的代码理解了半天。。。。只能说位运算真的很神奇
要求是A异或B后产生的数大于max(A,B)。所以 可以想到,对A且的运算可以得到A的0的最高位的位置。1^0=1,那么只要找在最高位右边的数就可以了。
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
int T,i,j,n,a[100005],sum,bit[100005],l;
scanf("%d",&T);
while(T--)
{
sum=0;
memset(bit,0,sizeof(bit));
scanf("%d",&n);
for(j=0;j<n;j++)
{
scanf("%d",&a[j]);
for(i=31;i>=0;i--)
if(a[j]&(1<<i))      //对每个数进行0的最高位的查找
{
bit[i]++;
break;
}

}
for(i=0;i<n;i++)
{
l=31;
while(1)
{
if(a[i]&(1<<l))break;
l--;
}
while(l--)    //只要将后面的0变为1,数一定会变大
{
if(!(a[i]&(1<<l)))sum+=bit[l];
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: