您的位置:首页 > 运维架构

UVa 714 Copying Books

2015-04-27 21:28 405 查看


  Copying Books 
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after
several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was
to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books.
Imagine you have m books (numbered 

) that may have different number of pages ( 

)
and you want to make one copy of each of them. Your task is to divide these books among k scribes, 

. Each book can be assigned
to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers

 such
that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore,
our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there
are two integers m and k, 

. At the second line, there are integers

 separated
by spaces. All these values are positive and less than 10000000.

Output 

For each case, print exactly one line. The line must contain the input succession 

 divided
into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between
the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100


Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100


Miguel A. Revilla 

2000-02-15

#include <cstdio>

bool judge(long long x);

long long book[510];
int b_count = 0;
int p_count = 0;

long long place[510];

int main()
{
int num;
scanf("%d", &num);
int count = 0;
place[0] = 0;
while(count < num)
{
scanf("%d%d", &b_count, &p_count);
long long sum = 0;
for(int i = 1; i <= b_count; i++)
{
scanf("%lld", &book[i]);
sum += book[i];
}

long long begin = 1, end = sum;
while(end > begin)
{
//	printf("begin: %lld end: %lld mid: %lld\n", begin, end, (begin + end) / 2);
long long mid = (begin + end) / 2;
if(judge(mid))
end = mid;
else
begin = mid+1;
}
//		printf("end: %lld\n", end);
place[p_count] = b_count+1;
for(int i = p_count-1; i >= 1; i--)
{
long long t_sum = book[place[i+1]-1];
int t_place = place[i+1]-1;
while(t_sum <= end && t_place >= i+1)

//			while(t_sum <= end)
{
t_place--;
t_sum += book[t_place];
}
t_place++;
place[i] = t_place;
}
int n_count = 1;
for(int i = 1; i <= b_count; i++)
{
if(i > 1)
printf(" ");
if(n_count <= p_count-1 && place[n_count] == i)
{
printf("/ ");
n_count++;
}
printf("%lld", book[i]);
}
printf("\n");
count++;
}
return 0;
}

// 判断book能不能划分至间隔最大值不大于x
bool judge(long long x)
{
int i = 1;
for(; i <= p_count-1; i++)
{
long long t_sum = book[place[i-1]+1];
int t_place = place[i-1]+1;
while(t_sum <= x && (b_count-t_place) >= p_count-i)
{
t_place++;
t_sum += book[t_place];
}
if(t_place != place[i-1]+1)
t_place--;
else
return false;
place[i] = t_place;
}

long long t_sum = 0;
long long t_place = place[p_count-1]+1;
while(t_place <= b_count)
{
t_sum += book[t_place];
t_place++;
}
return t_sum <= x;
}


这题没有想出来。看了书得到的解法是:
判断最大值为确定的数x是否可行, 只需要O(n). 从左到右扫描一遍即可。
这样就从1至所有数的和X,二分查找最小的可行整数。复杂度为O(nlogX).
提供的思路是先看看最大值为某个确定的数(验证解)的时间复杂度,再想方法。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: