您的位置:首页 > 其它

01背包问题:poj 3624 Charm Bracelet

2015-04-27 21:16 218 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 25953Accepted: 11672
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the
N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight
Wi (1 ≤ Wi ≤ 400), a 'desirability' factor
Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than
M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:
Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

刚开始的时候数组开到5000,结果RE了,改大数组之后就AC了。

#include<iostream>
#include<cstring>
using namespace std;
const int MAX=20000;
int dp[MAX];
int main()
{
int N,M;
while(cin>>N>>M)
{

int w[MAX];
int v[MAX];
memset(dp,0,sizeof(dp));
for(int i =1 ;i <= N; i ++ )
cin>>w[i]>>v[i];
for(int i = 1; i <= N;i ++){
for(int j =M ;j >= w[i]; j--){
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}
}
cout<<dp[M]<<endl;
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: