您的位置:首页 > 大数据 > 人工智能

动态规划: HDU 1789Doing Homework again

2015-04-27 20:22 288 查看
[align=left]Problem Description[/align]
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

[align=left]Output[/align]
For each test case, you should output the smallest total reduced score, one line per test case.

[align=left]Sample Input[/align]

3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4

[align=left]Sample Output[/align]

0 3 5

可以将作业按扣分高低排序,每次找到扣分最高的,将它安排进终止日期那一天,如果那天有事,就在往前推,,如果最后安排不下,就扣分。这样循环n次就可以了。
sort排序。。。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#define N 1100
using namespace std;

bool hh
;
typedef struct nod{
int x,y;
}s
;

bool cmp(nod a,nod b)
{
if(a.y!=b.y)
return a.y>b.y;
else
return b.x>a.x;
}
int main()
{
nod s
;
int T,n,i,j,sum;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&s[i].x);
}
for(i=1;i<=n;i++)
scanf("%d",&s[i].y);
sort(s+1,s+n+1,cmp);
sum=0;
memset(hh,false,sizeof(hh));
for(i=1;i<=n;i++)
{
for(j=s[i].x;j>0;j--)
{
if(hh[j]==false)
{
hh[j]=true;
break;
}
}
if(j==0)
{
sum=sum+s[i].y;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: